Ford Focus ST Forum banner

21 - 27 of 27 Posts

·
Registered
Joined
·
123 Posts
ya sorry, since the cord that came with it was about 3 feet with the lighter socket I just cut the socket off, spliced about 3 more feet then used the add a fuse kit to hook it in the fuse box.
 

·
Registered
Joined
·
8 Posts
Thanks for the write up, the add-a-fuse was super helpful!
Now just debating on keeping my 8500 or getting a Redline or Max.
 

·
Registered
Joined
·
2 Posts
Thank you so much for this write up. I was messing around with trying to hardwire my V1 into the moonroof for power, and I finally gave up and switched to your approach with the add a fuse. You saved me a bunch of time with your pictures and instructions. Thanks again!
 

·
Registered
Joined
·
6 Posts
For those of you who did this installation in the ST3, have you experienced any interference from the navigation system? I read that nav systems tend to interfere with RD's if they are mounted right above them. I'm getting my 9500ix in the mail soon, so I may just give it a go in that position for awhile before going through with the hard wire.
 

·
Registered
Joined
·
2 Posts
For those of you who did this installation in the ST3, have you experienced any interference from the navigation system? I read that nav systems tend to interfere with RD's if they are mounted right above them. I'm getting my 9500ix in the mail soon, so I may just give it a go in that position for awhile before going through with the hard wire.
I have an ST3 and run a valentine 1 with a blendmount from the rear view mirror, and I haven't had any issues with interference. That said - I don't use the nav system very often. Hopefully others can chime in.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #26
For those of you who did this installation in the ST3, have you experienced any interference from the navigation system? I read that nav systems tend to interfere with RD's if they are mounted right above them. I'm getting my 9500ix in the mail soon, so I may just give it a go in that position for awhile before going through with the hard wire.
I ran this setup in my ST3 and never had any issues with either the Nav or the RD (9500ix).
 

·
Registered
Joined
·
6 Posts
Went cruising with the 9500ix last night and I didn't seem to have any sort of interference from the Nav system. Time to order that mount!
 
21 - 27 of 27 Posts
Top