Ford Focus ST Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
This is my first thread, so sorry if it is posted in the wrong place.

Great Forum and Im stoked to be apart of the ST Nation!

I installed Cobbs cold air intake on my new ST after the break in period. Everything went smooth I followed all the instruction correctly and everything fit how it said. I then took it for a spin and it felt and sounded really good. I got a good power increase. After 30 miles I stopped and turned the car off when I started it again the check engine light was on.

I rechecked the install everything was connected properly. I then drove another 30 miles to see if the computer needed to reset but the light stayed on.

Any insight would be really helpful!!!

Thanks for the HELP!!
 

·
Registered
Joined
·
532 Posts
One major thing that can be affected with intakes is the MAP sensor. If water or oil or anything get onto it you may get a CEL.
I would suggest this b/c it is cheap and easy. Try cleaning the sensor and re-installing. Plus you will have this cleaner for the future. It isn't a bad idea to clean the sensor every time you clean or replace your air filter.

This stuff should work:
CRC/Mass air flow sensor cleaner (05110) | | AutoZone.com

Otherwise talk to Cobb. They may know something specific to look at.
 

·
Registered
Joined
·
650 Posts
Before I do anything I would read the code. Attempting to fix/clean/replace anything right now is a shot in the dark without at least knowing what the code is for.
 

·
Registered
Joined
·
862 Posts
True.
If you have access to a code reading device of some sort....
Well, I imagine he has an AP, which can read codes. And if he doesn't, he should get one to not only get the most out of his intake, but also get the most out of his ST.
 
  • Like
Reactions: RPhilMan1

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
Thanks for you help guys! I dont have an AP. I had to get an oil change this morning and the guy at ford noticed it and is going to take a look. I seriously hope he doesn't void my warranty. I will post what they say in a couple hours.
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #7 ·
I just got the car back from ford and the said that there was no code triggered. The light was just on I guess. They turned it off. So i will just see if it stays off. Has anyone ever heard of this?
 

·
Registered
Joined
·
650 Posts
I just got the car back from ford and the said that there was no code triggered. The light was just on I guess. They turned it off. So i will just see if it stays off. Has anyone ever heard of this?
There should be a DTC stored for the light to be on. Many times there can be a DTC stored with no light on, but not the other way around. See if it comes back.

FWIW, any auto parts store will read the code for free, they just can't clear them anymore.
 
1 - 8 of 8 Posts
Top