Ford Focus ST Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hello, I have a 2017 ST with about 67,000 miles running the stock tune. Me and my wife were driving back home on a 300 mile trip cruising about 70 the whole way. During the last hour I notice the cruise control cut off and saw the rpm and speed going down, thinking I hit the button I shifted down to 5 to get back up to speed, only to notice it's not responding. I pulled over and threw it into neutral and gave it a little gas, it seemed like it was working, but it went about 5 miles down the road and did it again and actually died this time. I let the car chill for a few minutes and got it going again trying to find a AutoZone and made it, however it did act up a few times. Got the code read and she said it was a throttle position sensor but no one had any nearby. I let the car rest for about 40 minutes let head and frustration calm down and tried again, started up fine drove good. About 20 miles on the road it started to do it again and died a few times but as I let it sit for a few minutes I finally limped it back home. I already got throttle body on order, but while I wait is there anything else I should check. Also the last 10 or 15 miles as the throttle cut off I downshift to 4th as the rpms went it it came back to life and didn't die and stayed running until I got home.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #2 ·
So update stated the car and still had a engine light, took it to AutoZone here and got it read came up as p00c6 fuel rail pressure too low. Drove it around some more and no hesitation nor struggling and no engine light again. Has anyone had this issue before, also I did get gas at a walmart but if said gas was bad would that have caused my stalling and engine to die while I was driving?
 
1 - 3 of 3 Posts
Top